Game crash during friend request

Report any bugs you find here. Include the steps for reproducing it if you can, and the version number.
Sat Jul 29, 2017 4:54 am

  • Switching between the 'Friends' tab and 'Requests' tab on the friends list sub-menu has always caused the game to hang (while it connects to the server/database that contains the relevant information).

    The lag it causes is noticeable to varying degrees, for me it's been getting steadily worse for a while, it causes my screen to hang for around 20 seconds.

    Sometimes it will hang long enough to cause a 'not responding' error to occur (this prompts the option to shut the window down or wait for it to respond).

    This also occurs to a slightly lesser degree when switching between the staff inventory menu and the main menu, the screen hangs while it retrieves the information listing all the gear you own.

    As the friends list grows and the staff inventory list grows the lag gets worse.

    An unusual glitch occurred yesterday whilst sending a friend request..

    ..The screen hung for a few seconds, while my game window was still in an unresponsive state the other player accepted the request and immediately sent me an ally request, this appeared to cause my game to crash (it wasn't able to recover from the 'not responding' error).

    After I forced the game to shutdown I logged back in, I could see that the player had been successfully added to my friends list but when they tried to send me ally requests I wasn't receiving any pop up notifications prompting me to join.. something's awry.
    User avatar
    Mazy
     
    Posts: 1698
    Joined: Mon Oct 06, 2014 8:24 pm
    Location: UK

Mon Jul 31, 2017 6:48 am

  • yup this is a thing as it happens to me a lot as well.

    always when requesting an ally and your friend list appears. it hangs and i always have to end up end tasking the game and relaunching it.

    similar hanging has pretty much always happened since the friends list was first introduced.

    It is like it throws a wobbly when trying to update peoples status or if you are in it and then either someone leaves or comes online and it panics not knowing what to do.

    what ever the reason its rather annoying.
    Last edited by gary on Mon Jul 31, 2017 9:02 am, edited 2 times in total.
    R Tape loading error, 0:1
    User avatar
    gary
    DEMIGOD
     
    Posts: 1211
    Joined: Tue Jan 21, 2014 7:51 pm

Mon Jul 31, 2017 7:53 am

  • Added to our bug tracking database, thanks for reporting this.
    User avatar
    CGR
    SNAPSHOT DEV
     
    Posts: 220
    Joined: Tue Mar 10, 2015 11:26 am
    Location: Seascale, Cumbria, UK



Return to Bug Reports




Information
  • Who is online
  • Users browsing this forum: No registered users and 1 guest