[GOG v1.131 linux] after start no graphics, only sound

Report any bugs you find here. Include the steps for reproducing it if you can, and the version number.

  • I have linux version from GOG v1.131 on GOG page, file name: "chaos_reborn_en_1_131_14290.sh" (also the a bit older named installer "gog_chaos_reborn_2.14.0.16.sh" behaves in the same way).

    Installation is smooth, but when I run the game, I can hear sound of intro movie, and then the background music plays, and I can see mouse cursor, but nothing else, just black screen except working mouse cursor. I did wait few minutes to make sure the invisible menu would be loaded, but even then there's nothing clickable in the black screen, so it looks like the menu scene is truly not being rendered at all, probably not just graphical glitch or driver issue.

    This is console output from start.sh (full path redacted from all outputs to "..."):
    Code: Select all
    ...gog/play/ChaosReborn_LastVersion$ ./start.sh
    Running Chaos Reborn
    Set current directory to ...gog/play/ChaosReborn_LastVersion/game
    Found path: ...gog/play/ChaosReborn_LastVersion/game/ChaosRebornLinux.x86_64
    Mono path[0] = '...gog/play/ChaosReborn_LastVersion/game/ChaosRebornLinux_Data/Managed'
    Mono path[1] = '...gog/play/ChaosReborn_LastVersion/game/ChaosRebornLinux_Data/Mono'
    Mono config path = '...gog/play/ChaosReborn_LastVersion/game/ChaosRebornLinux_Data/Mono/etc'
    Preloaded 'ScreenSelector.so'
    Preloaded 'libCSteamworks.so'
    Preloaded 'libsteam_api.so'
    Player data archive not found at `...gog/play/ChaosReborn_LastVersion/game/ChaosRebornLinux_Data/data.unity3d`, using local filesystem


    My OS:
    NEON distro (Ubuntu 16.04 with latest KDE5 desktop environment):
    Code: Select all
    uname -a
    Linux compname 4.4.0-93-generic #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


    Any idea what further logs can be gathered from the game, etc? I'm a bit suspicious about the "steam" shared libraries, does the game gracefully operate even when no trace of steam (client and/or any user account) is on the OS? (I never ever used steam, nor I plan to)

    ----

    The previous version installed from "gog_chaos_reborn_2.13.0.15.sh" still works well for me (except of course inability to connect to multiplayer due to version mismatch), running the older start.sh does produce this:

    Code: Select all
    ...gog/play/ChaosReborn$ ./start.sh
    Running Chaos Reborn
    Set current directory to ...gog/play/ChaosReborn/game
    Found path: ...gog/play/ChaosReborn/game/ChaosRebornLinux.x86_64
    Mono path[0] = '...gog/play/ChaosReborn/game/ChaosRebornLinux_Data/Managed'
    Mono path[1] = '...gog/play/ChaosReborn/game/ChaosRebornLinux_Data/Mono'
    Mono config path = '...gog/play/ChaosReborn/game/ChaosRebornLinux_Data/Mono/etc'


    The sound output is basically same (just tad quicker start in tenths of second), but the intro movie has graphics, and then the loading progress is shown, and finally menu is visible and all items clickable in it.
    Ped7g
     
    Posts: 7
    Joined: Thu Jan 07, 2016 12:03 am




Return to Bug Reports




Information
  • Who is online
  • Users browsing this forum: Google [Bot] and 1 guest