[WORKAROUND] GFX problem: 1.131 (GOG) unplayable

Report any bugs you find here. Include the steps for reproducing it if you can, and the version number.

  • Hello,

    I just installed the 1.131 GOG version and when I try to start CR all I get is a badly jumbled mess (that is also invisible until I set my window manager to put CR into fullscreen and back).

    The version I had installed previously (, 1.122 GOG?) worked fine today (I just got an error message about the version mismatch with the server).

    Linux (Bedrock Linux with Devuan) x86_64
    [AMD/ATI] RV790 [Radeon HD 4890]
    radeon xorg driver (xserver-xorg-video-radeon 1:7.8.0-1~bpo8+1)

    edit: note workaround in title
    output on console:
    Code: Select all
    Running Chaos Reborn
    Set current directory to /mnt/Games/gog.com/Chaos_Reborn/game
    Found path: /mnt/Games/gog.com/Chaos_Reborn/game/ChaosRebornLinux.x86_64
    Mono path[0] = '/mnt/Games/gog.com/Chaos_Reborn/game/ChaosRebornLinux_Data/Managed'
    Mono path[1] = '/mnt/Games/gog.com/Chaos_Reborn/game/ChaosRebornLinux_Data/Mono'
    Mono config path = '/mnt/Games/gog.com/Chaos_Reborn/game/ChaosRebornLinux_Data/Mono/etc'
    Preloaded 'ScreenSelector.so'
    Preloaded 'libCSteamworks.so'
    Preloaded 'libsteam_api.so'
    Player data archive not found at `/mnt/Games/gog.com/Chaos_Reborn/game/ChaosRebornLinux_Data/data.unity3d`, using local filesystem

    gameinfo file:
    Code: Select all
    Chaos Reborn

    Full re-installation did not help. The file I downloaded from GOG is
    chaos_reborn_en_1_131_14290.sh with
    sha256sum: 5f6e3a668f3343de4072c239a8ecea59e00c7183df2d979313eff5067124f743

    Strangely, I also have two directories in ~/.config/unity3d/:

    "Snapshot Games Inc_" and "Snapshot Games Inc."

    Code: Select all
    Snapshot Games Inc./Chaos Reborn:
    total 28
    drwxr-xr-x 3 gamer gamer  4096 Feb 26  2016 OfflineData
    -rw-r--r-- 1 gamer gamer 10554 Dec  2 22:59 Player.log
    drwxr-xr-x 3 gamer gamer  4096 Dec  2 23:30 Unity
    -rw-r--r-- 1 gamer gamer  4694 Dec  2 22:59 prefs


    Snapshot Games Inc_/Chaos Reborn:
    total 12
    -rw-r--r-- 1 gamer gamer 8105 Dec  2 23:46 Player.log
    -rw-r--r-- 1 gamer gamer 1018 Dec  2 23:46 prefs

    (both Player.log attached)

    Please let me know if I can provide further information.
    (5.35 KiB) Downloaded 31 times
    Last edited by dumfsirg on Sun Dec 03, 2017 11:43 am, edited 1 time in total.
    Posts: 77
    Joined: Thu Dec 11, 2014 7:18 pm

  • Hello Rafi,

    Thank you!

    Putting the value to 0 on the line
    <pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
    in the prefs file largely solved it for me, too :-)

    The only glitch remaining for me so far is that the custom mouse cursor has grown an extra "corner" (see photo attached) but when targeting with the upper left corner it works fine and thankfully the UI elements in CR are rather large so it's not that big an issue (although a fix would be nice!).

    On the issue with the two directories I just use now the one with the newest time stamp (with the underscore) and copied the prefs file from the other (since it had more customization entries in it) and so far it works well.

    See you on the shards (meh, been away so long /me even forgot basic lore vocabulary :S)
    corrupted mouse pointer
    20171203_122147.jpg (68.16 KiB) Viewed 533 times
    Posts: 77
    Joined: Thu Dec 11, 2014 7:18 pm

  • Thanks for posting your workaround, I'll add the info the the bug database entry on this problem.
    User avatar
    Posts: 1277
    Joined: Sat Apr 05, 2014 11:36 am
    Location: Cumbria, UK

Return to Bug Reports

  • Who is online
  • Users browsing this forum: No registered users and 3 guests